CentOS6.2版本用yum升级到CentOS6.6

分类:CentOS教程 阅读:55098 次

因为手上只有6.2版本的CentOS,安装好后觉着版本太低了,就通过命令行进行升级
查看可用的更新
#yumlist updates
更新升级到centos 6.5
#yumupdate

不幸的是,我在这次的更新过程中,出现了一些错误

Error: Package: matahari-host-0.4.4-11.el6.i686 (@anaconda-CentOS-201112130233.i386/6.2)
Requires: libqpidclient.so.5
Removing: qpid-cpp-client-0.12-6.el6.i686 (@anaconda-CentOS-201112130233.i386/6.2)
libqpidclient.so.5
Updated By: qpid-cpp-client-0.14-22.el6_3.i686 (base)
Not found
Error: Package: matahari-service-0.4.4-11.el6.i686 (@anaconda-CentOS-201112130233.i386/6.2)
Requires: libqpidclient.so.5
Removing: qpid-cpp-client-0.12-6.el6.i686 (@anaconda-CentOS-201112130233.i386/6.2)
libqpidclient.so.5
Updated By: qpid-cpp-client-0.14-22.el6_3.i686 (base)
Not found

根据它的提示,执行命令
# yum update --skip-broken

# rpm -Va --nofiles --nodigest
都不行,经过网络搜索找到解决办法:
1、先卸载qpid-cpp-client
# yum -y remove qpid-cpp-client
2、清除重建缓存
# yum clean all
# yum makecache
3、重新执行更新动作
# yum update