解决Exchange2010 EMC批量启用邮箱之后出现乱码问题

分类:CentOS运维 阅读:88771 次

平时大家在做Exchange 项目的时候都是需要批量导入AD账户和批量启用AD账户的邮箱,但是有一个比较奇怪的问题是当你使用Exchange 2010 EMC来批量启用邮箱之后会出现乱码问题,并且邮箱用户不能发送和接收电子邮件,那么该如何处理乱码问题呢?不要着急,其实有3种方法可以处理Exchange 2010批量启用邮箱之后出现乱码问题,第一种方法是批量修改Exchange 2010邮箱的别名,第二种方法是使用EMS来批量启用邮箱,最后一种方法是使用脚本来批量创建AD账户,这种方法批量创建AD账户之后,你会发现使用Exchange 2010 EMC批量启用邮箱之后也不会出现乱码问题,在介绍处理方法之前首先给大家看一下实验环境拓朴图,此实验环境拓朴图是小弟自己画的图,由于平时没有画图的习惯,可能画出来的图没有大家画的那么专业吧!呵呵,废话少说了,首先看看下面实验环境拓朴图了解一下实验环境:

解决Exchange2010 EMC批量启用邮箱之后出现乱码问题

第一种处理乱码问题的方法:批量修改Exchange 2010邮箱的别名

步骤一:请您将下列内容copy到一个记事本中,并把这个文件存为bulk.ps1文件。请特别注意:此文件的扩展名为.ps1

$list=Get-Mailbox

ForEach ($item in $list)

{

$user=Get-User $item

$sam=$user.SAMAccountName

Set-Mailbox $item ?Alias "$sam"

}

步骤二:把bulk.ps1文件保存到Exchange 2010本地C:\盘根目录下。然后打开Exchange Management Shell:

输入:

C:\bulk.ps1

然后回车。

做完上述步骤后,您应该可以看到所有用户邮箱的别名都改成了登录名。

注:$list=Get-Mailbox代表邮箱变量。

$item代表每个邮箱的属性变量。

$sam=$user.SAMAccountName代表每个用户的登录名变量

解决Exchange2010 EMC批量启用邮箱之后出现乱码问题

可以看到我使用Exchange 2010 EMC一次启用200个用户邮箱已经完成了

解决Exchange2010 EMC批量启用邮箱之后出现乱码问题

可以看到用户邮箱别名这一列全部显示成乱码

解决Exchange2010 EMC批量启用邮箱之后出现乱码问题

在EMS里面执行C盘里面保存的bulk.ps1文件

解决Exchange2010 EMC批量启用邮箱之后出现乱码问题

可以看到现在用户邮箱别名这一列全部显示正常了,但是这种方法处理乱码问题不太可靠,当你在企业生产环境中使用这种方法处理超过6000用户邮箱的乱码问题的时候会一直没起什么作用,不管执行多少次这个脚本文件都没起作用,用户邮箱的别名还是显示乱码。

第二种处理乱码问题的方法:使用Exchange 2010 EMS来批量启用AD账户邮箱

命令示例:
function NewMailUser
{
Enable-Mailbox -Identity ($_.split(","))[0] -Alias ($_.split(","))[1]
}
gc mb.csv | foreach {NewMailUser}

注意:
其中“function”为整个脚本定义函数,“NewMailUser”为定义的函数
大括号中的为启用邮箱Powershell 命令,“($_.split(","))[0]”代表调用CSV 文本文件内编号为0 的
的列,分隔符为逗号
其中“Gc mb.csv”代表被调用的CSV 文件
管道符后的“foreach ”为批量执行函数“NewMailUser”直到CSV 文件行尾

解决Exchange2010 EMC批量启用邮箱之后出现乱码问题

可以看到这次我使用Exchange 2010 EMC一次启用1000个用户邮箱已经完成了

解决Exchange2010 EMC批量启用邮箱之后出现乱码问题

在收件人配置的邮箱里面把这1000个乱码用户邮箱全部禁用掉

解决Exchange2010 EMC批量启用邮箱之后出现乱码问题

可以看到我使用EMS来批量启用这1000个用户邮箱都显示正常了,并且这1000个用户邮箱会自动分配到4台Exchange 2010 邮箱服务器里面。

解决Exchange2010 EMC批量启用邮箱之后出现乱码问题

在Exchange 2010 EMC的收件人配置的邮箱里面可以看到刚才使用EMS启用的1000乱码用户邮箱的别名全部显示正常了

第三种处理乱码问题的方法:使用脚本批量创建AD账户

解决Exchange2010 EMC批量启用邮箱之后出现乱码问题

从上面一张截图可以看到Excel表里面有2368个用户信息

解决Exchange2010 EMC批量启用邮箱之后出现乱码问题

修改脚本文件执行Excel文件的路径

解决Exchange2010 EMC批量启用邮箱之后出现乱码问题

执行脚本文件

解决Exchange2010 EMC批量启用邮箱之后出现乱码问题

在ADUC里面可以看到通过脚本文件调用Excel表格里面的用户信息来不断地添加AD账户,这种方法批量创建AD账户很花时间的,自己看了一下时间好像是花了3个小时左右才能够全部把2368个用户导入AD里面。

解决Exchange2010 EMC批量启用邮箱之后出现乱码问题

从上面一张截图可以看到我使用Exchange 2010 EMC一次启用刚才批量创建的2368个AD账户邮箱已经完成了

解决Exchange2010 EMC批量启用邮箱之后出现乱码问题

可以看到这2368个用户邮箱全部显示正常,没有出现乱码问题。这种方法可以处理使用EMC批量启用邮箱之后出现乱码问题,但是这种方法比较麻烦并且又慢,像一些大公司下面有很多家分公司和很多个部门,这样在AD里面创建一级OU和二级OU之后,然后通过这种方法来批量创建AD账户是比较麻烦的,需要在Excel表格里面把公司、部门和用户信息都排好才能够顺利批量创建AD账户。

解决Exchange2010 EMC批量启用邮箱之后出现乱码问题

可以看到DAG-Node22这台邮箱服务器里面有4块硬盘,硬盘符号分别是E、G、H和I。另外三台邮箱服务器DAG-Node23、DAG-Node26和DAG-Node28里面也同样有4块硬盘,并且硬盘符号同样是E、G、H和I。注意:每一块硬盘都是存放一个主数据库和另外三台邮箱服务器数据库的副本。

解决Exchange2010 EMC批量启用邮箱之后出现乱码问题

从上面一张截图可以看到我已经把DAG-Node22、DAG-Node23、DAG-Node26和DAG-Node28这四台邮箱服务器做成DAG了

解决Exchange2010 EMC批量启用邮箱之后出现乱码问题

从上面一张截图可以看到目前有16个主数据库分别存放在4台邮箱服务器里面,每台邮箱服务器存放4个主数据库,并且每个主数据库都已经把另外三台邮箱服务器的数据库添加作为副本了。

解决Exchange2010 EMC批量启用邮箱之后出现乱码问题

从上面一张截图可以看到现在的Excel表格里面有11073个AD用户信息

解决Exchange2010 EMC批量启用邮箱之后出现乱码问题

解决Exchange2010 EMC批量启用邮箱之后出现乱码问题

在Exchange 2010 EMS里面使用命令调用Excel表格里面的11073个AD用户信息来全部启用邮箱。

注意:这11073个用户邮箱会自动分配到四台邮箱服务器的16块硬盘的16个数据库里面,自己看了一下时间大概是80分钟左右就能够把11073个AD账户的邮箱全部启用

解决Exchange2010 EMC批量启用邮箱之后出现乱码问题

在Exchange 2010 EMC的收件人配置的邮箱里面可以看到有11073个用户邮箱了,并且全部用户邮箱都显示正常,没有出现乱码问题。

解决Exchange2010 EMC批量启用邮箱之后出现乱码问题

输入上面一张截图的命令把DAG-Node28 DB1这个数据库的信息导出成csv文件

解决Exchange2010 EMC批量启用邮箱之后出现乱码问题


可以看到在DAG-Node28 DB1这个数据库里面自动分配了690多个邮箱用户,从这可以看出通过EMS来批量启用邮箱是平均分配到相应的邮箱数据库里面的,690X16差不多就是11073个邮箱了

解决Exchange2010 EMC批量启用邮箱之后出现乱码问题

在Exchange 2010 OWA的默认全局地址列表里面可以看到这11073个用户邮箱的信息,如果想查看某一个人的详细信息就在空白方框里面输入他的登录名,然后回车就行了。

解决Exchange2010 EMC批量启用邮箱之后出现乱码问题

好了,本篇文章主要介绍了三种方法处理使用Exchange 2010批量启用邮箱之后出现乱码问题,希望这篇文章给大家在工作和学习中带来很大帮助。

本文出自 “叶俊生” 博客,请务必保留此出处http://yejunsheng.blog.51cto.com/793131/488962