centos下对gcc降级

分类:CentOS教程 阅读:36963 次

因为vmware 安装了centos 6.2(64位)桌面版,但是vmware tools安装失败的问题,无意中把gcc版本从4.6.6升到了4.6.7,于是开始了gcc降级之旅。

首先yum erase gcc

然后比对着这篇文章 http://blog.csdn.net/vah101/article/details/17677451 和centos安装光盘重新安装gcc

1.rpm -ecpp-4.4.7

2.rpm-ivhcpp-4.4.6-3.el6.x86_64.rpm

3.rpm -Ukernel-headers-2.6.32-220.el6.x86_64.rpm--oldpackage

4.rpm -ivhkernel-headers-2.6.32-220.el6.x86_64.rpm

5.rpm -e glibc-2.12-1.132.el6.i686

6.rpm -Uvh glibc-2.12-1.47.el6.x86_64.rpm glibc-common-2.12-1.47.el6.x86_64.rpm --force --nodeps --oldpackage

7.rpm -e glibc-headers-2.12-1.132.el6.x86_64 glibc-devel-2.12-1.132.el6.x86_64 compat-gcc-34-3.4.6-19.el6.x86_64 compat-gcc-34-g77-3.4.6-19.el6.x86_64 compat-gcc-34-c++-3.4.6-19.el6.x86_64

8.rpm -ivhglibc-headers-2.12-1.47.el6.x86_64.rpm

9.rpm -ivhglibc-devel-2.12-1.47.el6.x86_64.rpm

10.rpm -e libgomp-4.4.7 gettext-0.17-16.el6.x86_64 gettext-devel-0.17-16.el6.x86_64 redhat-lsb-4.0-3.el6.centos.x86_64 intltool-0.41.0-1.1.el6.noarch

11.rpm -ivhlibgomp-4.4.6-3.el5.x86_64.rpm

12.rpm -e libstdc++-devel-4.4.7

13.rpm -e libstdc++-4.4.7-4.el6.x86_64

14.rpm -ivh gcc-c++-4.4.6-3.el6.x86_64.rpm libstdc++-4.4.6-3.el6.x86_64.rpm libstdc++-devel-4.4.6-3.el6.x86_64.rpm --oldpackage

大功告成,总的原则就是--oldpackage安装失败,就卸载新版本的库,以及依赖的库,然后再安装旧版库。

此工程比较耗费时间,可能还有更好的方法,抛砖引玉吧!