CentOS安装中文汉字输入法ibus

分类:CentOS教程 阅读:96155 次

新安装的CentOS没有默认没有装语言支持(Language Support),因此很不方面。

终于发现了有效的方法:

su root

yum install "@Chinese Support"

exit

然后设置Input Methord即可。

最后一步:logout,注意是注销,然后再次登录此用户。

引用:http://www.cyberciti.biz/faq/linux-install-language-support/

LinuxFAQ / Howtos
Install Language support in CentOS 5 or Red Hat Enterprise Linux
by Vivek Gite on June 15, 2007 · 8 comments

Q. How do I install Languages in Linux after installation? I don’t have any language specific support installed but need to install the same. I’m using both RHEL 5 and CentOS 5.

A. Yellow dog Updater, Modified, a package manager for RPM-compatible Linux systems such as CentoS 5/Fedora 7 and RHEL 5. Yum's repository system is quickly becoming the standard for RPM-based repositories.

If the languages were not installed during the installation, the same can be installed by YUM command. Use following command to install Hindi and Chinese support.

# yum groupinstall {LANGUAGE-support}

# yum install "@Hindi Support"
# yum install "@Chinese Support"

Use yum grouplist list available groups and languages.

[Jeffery@CentOS ~]$ su root
密码:
[root@CentOS Jeffery]# yum install "@Chinese Support"
Loaded plugins: fastestmirror, refresh-packagekit, security
Repository base is listed more than once in the configuration
Repository updates is listed more than once in the configuration
Repository extras is listed more than once in the configuration
Repository centosplus is listed more than once in the configuration
Repository contrib is listed more than once in the configuration
Loading mirror speeds from cached hostfile
base| 3.7 kB00:00
extras| 3.5 kB00:00
google-chrome|951 B00:00
updates| 3.4 kB00:00
updates/primary_db| 4.0 MB00:02
Setting up Install Process
Loading mirror speeds from cached hostfile
Package cjkuni-uming-fonts-0.2.20080216.1-35.el6.noarch already installed and latest version
Package wqy-zenhei-fonts-0.9.45-3.el6.noarch already installed and latest version
Resolving Dependencies
--> Running transaction check
---> Package cjkuni-ukai-fonts.noarch 0:0.2.20080216.1-35.el6 will be installed
---> Package ibus-chewing.i686 0:1.3.5.20100714-4.el6 will be installed
--> Processing Dependency: libchewing >= 0.3.2-16 for package: ibus-chewing-1.3.5.20100714-4.el6.i686
--> Processing Dependency: ibus >= 1.1 for package: ibus-chewing-1.3.5.20100714-4.el6.i686
--> Processing Dependency: libibus.so.2 for package: ibus-chewing-1.3.5.20100714-4.el6.i686
--> Processing Dependency: libchewing.so.3 for package: ibus-chewing-1.3.5.20100714-4.el6.i686
---> Package ibus-pinyin.i686 0:1.3.8-1.el6 will be installed
---> Package ibus-table-cangjie.noarch 0:1.2.0.20100210-1.el6 will be installed
--> Processing Dependency: ibus-table >= 1.2.0.20100111-2 for package: ibus-table-cangjie-1.2.0.20100210-1.el6.noarch
--> Processing Dependency: ibus-table >= 1.2.0.20100111-2 for package: ibus-table-cangjie-1.2.0.20100210-1.el6.noarch
---> Package ibus-table-erbi.noarch 0:1.2.0.20090901-8.el6 will be installed
---> Package ibus-table-wubi.noarch 0:1.2.0.20090715-8.el6 will be installed
--> Running transaction check
---> Package ibus.i686 0:1.3.4-6.el6 will be installed
--> Processing Dependency: ibus-gtk = 1.3.4-6.el6 for package: ibus-1.3.4-6.el6.i686
--> Processing Dependency: im-chooser >= 1.2.5 for package: ibus-1.3.4-6.el6.i686
--> Processing Dependency: pyxdg for package: ibus-1.3.4-6.el6.i686
--> Processing Dependency: notify-python for package: ibus-1.3.4-6.el6.i686
---> Package ibus-libs.i686 0:1.3.4-6.el6 will be installed
---> Package ibus-table.noarch 0:1.2.0.20100111-4.el6 will be installed
---> Package libchewing.i686 0:0.3.2-27.el6 will be installed
--> Running transaction check
---> Package ibus-gtk.i686 0:1.3.4-6.el6 will be installed
---> Package im-chooser.i686 0:1.3.1-3.el6 will be installed
--> Processing Dependency: imsettings >= 0.106.0 for package: im-chooser-1.3.1-3.el6.i686
--> Processing Dependency: libimsettings.so.4 for package: im-chooser-1.3.1-3.el6.i686
---> Package notify-python.i686 0:0.1.1-10.el6 will be installed
---> Package pyxdg.noarch 0:0.18-1.el6 will be installed
--> Running transaction check
---> Package imsettings.i686 0:0.108.0-3.6.el6 will be installed
--> Processing Dependency: libgxim.so.2 for package: imsettings-0.108.0-3.6.el6.i686
---> Package imsettings-libs.i686 0:0.108.0-3.6.el6 will be installed
--> Running transaction check
---> Package libgxim.i686 0:0.3.3-3.1.el6 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
PackageArchVersionRepository
Size
================================================================================
Installing:
cjkuni-ukai-fontsnoarch0.2.20080216.1-35.el6base9.4 M
ibus-chewingi6861.3.5.20100714-4.el6base61 k
ibus-pinyini6861.3.8-1.el6base1.1 M
ibus-table-cangjienoarch1.2.0.20100210-1.el6base4.9 M
ibus-table-erbinoarch1.2.0.20090901-8.el6base2.0 M
ibus-table-wubinoarch1.2.0.20090715-8.el6base2.0 M
Installing for dependencies:
ibusi6861.3.4-6.el6base334 k
ibus-gtki6861.3.4-6.el6base25 k
ibus-libsi6861.3.4-6.el6base96 k
ibus-tablenoarch1.2.0.20100111-4.el6base243 k
im-chooseri6861.3.1-3.el6base144 k
imsettingsi6860.108.0-3.6.el6base189 k
imsettings-libsi6860.108.0-3.6.el6base101 k
libchewingi6860.3.2-27.el6base1.5 M
libgximi6860.3.3-3.1.el6base122 k
notify-pythoni6860.1.1-10.el6base25 k
pyxdgnoarch0.18-1.el6base79 k

Transaction Summary
================================================================================
Install17 Package(s)

Total download size: 22 M
Installed size: 63 M
Is this ok [y/N]: y
Downloading Packages:
(1/17): cjkuni-ukai-fonts-0.2.20080216.1-35.el6.noarch.r | 9.4 MB00:04
(2/17): ibus-1.3.4-6.el6.i686.rpm| 334 kB00:00
(3/17): ibus-chewing-1.3.5.20100714-4.el6.i686.rpm|61 kB00:00
(4/17): ibus-gtk-1.3.4-6.el6.i686.rpm|25 kB00:00
(5/17): ibus-libs-1.3.4-6.el6.i686.rpm|96 kB00:00
(6/17): ibus-pinyin-1.3.8-1.el6.i686.rpm| 1.1 MB00:00
(7/17): ibus-table-1.2.0.20100111-4.el6.noarch.rpm| 243 kB00:00
(8/17): ibus-table-cangjie-1.2.0.20100210-1.el6.noarch.r | 4.9 MB00:01
(9/17): ibus-table-erbi-1.2.0.20090901-8.el6.noarch.rpm| 2.0 MB00:01
(10/17): ibus-table-wubi-1.2.0.20090715-8.el6.noarch.rpm | 2.0 MB00:02
(11/17): im-chooser-1.3.1-3.el6.i686.rpm| 144 kB00:00
(12/17): imsettings-0.108.0-3.6.el6.i686.rpm| 189 kB00:00
(13/17): imsettings-libs-0.108.0-3.6.el6.i686.rpm| 101 kB00:00
(14/17): libchewing-0.3.2-27.el6.i686.rpm| 1.5 MB00:02
(15/17): libgxim-0.3.3-3.1.el6.i686.rpm| 122 kB00:00
(16/17): notify-python-0.1.1-10.el6.i686.rpm|25 kB00:00
(17/17): pyxdg-0.18-1.el6.noarch.rpm|79 kB00:00
--------------------------------------------------------------------------------
Total1.2 MB/s |22 MB00:19
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
Installing : ibus-libs-1.3.4-6.el6.i6861/17
Installing : libgxim-0.3.3-3.1.el6.i6862/17
Installing : pyxdg-0.18-1.el6.noarch3/17
Installing : imsettings-libs-0.108.0-3.6.el6.i6864/17
Installing : imsettings-0.108.0-3.6.el6.i6865/17
Installing : im-chooser-1.3.1-3.el6.i6866/17
Installing : notify-python-0.1.1-10.el6.i6867/17
Installing : ibus-gtk-1.3.4-6.el6.i6868/17
Installing : ibus-1.3.4-6.el6.i6869/17
Installing : ibus-table-1.2.0.20100111-4.el6.noarch10/17
Installing : libchewing-0.3.2-27.el6.i68611/17
Installing : ibus-table-wubi-1.2.0.20090715-8.el6.noarch12/17
Installing : ibus-table-cangjie-1.2.0.20100210-1.el6.noarch13/17
Installing : ibus-table-erbi-1.2.0.20090901-8.el6.noarch14/17
Installing : cjkuni-ukai-fonts-0.2.20080216.1-35.el6.noarch15/17
Installing : ibus-chewing-1.3.5.20100714-4.el6.i68616/17
Installing : ibus-pinyin-1.3.8-1.el6.i68617/17
Verifying: libgxim-0.3.3-3.1.el6.i6861/17
Verifying: libchewing-0.3.2-27.el6.i6862/17
Verifying: ibus-gtk-1.3.4-6.el6.i6863/17
Verifying: ibus-pinyin-1.3.8-1.el6.i6864/17
Verifying: ibus-table-1.2.0.20100111-4.el6.noarch5/17
Verifying: notify-python-0.1.1-10.el6.i6866/17
Verifying: im-chooser-1.3.1-3.el6.i6867/17
Verifying: ibus-table-wubi-1.2.0.20090715-8.el6.noarch8/17
Verifying: imsettings-libs-0.108.0-3.6.el6.i6869/17
Verifying: ibus-table-cangjie-1.2.0.20100210-1.el6.noarch10/17
Verifying: ibus-libs-1.3.4-6.el6.i68611/17
Verifying: pyxdg-0.18-1.el6.noarch12/17
Verifying: ibus-table-erbi-1.2.0.20090901-8.el6.noarch13/17
Verifying: ibus-1.3.4-6.el6.i68614/17
Verifying: cjkuni-ukai-fonts-0.2.20080216.1-35.el6.noarch15/17
Verifying: ibus-chewing-1.3.5.20100714-4.el6.i68616/17
Verifying: imsettings-0.108.0-3.6.el6.i68617/17

Installed:
cjkuni-ukai-fonts.noarch 0:0.2.20080216.1-35.el6
ibus-chewing.i686 0:1.3.5.20100714-4.el6
ibus-pinyin.i686 0:1.3.8-1.el6
ibus-table-cangjie.noarch 0:1.2.0.20100210-1.el6
ibus-table-erbi.noarch 0:1.2.0.20090901-8.el6
ibus-table-wubi.noarch 0:1.2.0.20090715-8.el6

Dependency Installed:
ibus.i686 0:1.3.4-6.el6
ibus-gtk.i686 0:1.3.4-6.el6
ibus-libs.i686 0:1.3.4-6.el6
ibus-table.noarch 0:1.2.0.20100111-4.el6
im-chooser.i686 0:1.3.1-3.el6
imsettings.i686 0:0.108.0-3.6.el6
imsettings-libs.i686 0:0.108.0-3.6.el6
libchewing.i686 0:0.3.2-27.el6
libgxim.i686 0:0.3.3-3.1.el6
notify-python.i686 0:0.1.1-10.el6
pyxdg.noarch 0:0.18-1.el6

Complete!
[root@CentOS Jeffery]#