CentOS下安装php加解密工具php_screw-1.5

分类:CentOS教程 阅读:74232 次

以前用过php_screw工具的朋友一定非常喜欢他的小巧和开源免费。但是自从最后一个版本php_screw-1.5.tar.gz之后再也没有更新版本了,而旧的版本无法在php5.3以上的版本中使用。经过修改源码测试,修改过的版本可以在php5.3以上的版本中使用,所以分享给大家。

测试环境 centos 6.5 php5.6 apahche2.4.10

测试步骤:

1. 通过以下链接下载php_screw-1.5_php5.3.tgz 最新版本

http://download.csdn.net/detail/fengxupeng1979/8776279

2. tar zxvf php_screw-1.5_php5.3.tgz

3. 进入解压缩后的目录

4. 执行phpize命令

5. ./configure

6. make

7.拷贝modules目录下的php_screw.so文件到php的扩展目录下

8.编辑php.ini文件
在php.ini文件里,加入如下语句
extension=php_screw.so

9.重新启动Apache
/srv/apache/bin/apachectl restart
8. 编译加密工具
cd tools
make
9. 将tools目录下加密用的工具screw拷贝到适当目录
cp screw /usr/bin/

使用:

1. vim test.php 创建php文件。例如:

  1. <?php
  2. phpinfo();
  3. ?>

2. 执行 screw test.php将生成加密后的文件放到网页目录下通过浏览器访问查看是否正常。

如果没有生成加密过的test.php 文件,请查看screw的权限设置 chmod 755 /usr/bin/screw

3. 批处理脚本文件可以一次将整个目录的文件进行加密。

创建cryptphp.sh文件内容如下:

  1. #!/bin/sh
  2. DATE=`date+%Y%m%d%H%M`
  3. tarczf${DATE}bak.tgz$1
  4. find$1-name"*.php"-print|xargs-n1screw
  5. find$1-name"*.screw"-print|xargs-n1rm-v

4. 增加可执行权限后,加密你的代码吧。

ps:经测试php5.3 以上的版本是完全可用的,不过本着php开源的精神,还是希望大家多多分享代码,多多交流。使大家都可以得到提高。谢谢。