centos 升级git到高级版本

分类:CentOS教程 阅读:58839 次

为了使用github,安装了git,版本为1.7.1,对于追新的我,觉得这个版本有些老了。因为git版本都到2.2了。所以我决定升级到最新版本,为了你能不走弯路,请注意看三、四段。

一、先卸载旧版本的git。

#yum remove -y git

二、安装新版本的git

1、#wget 2、#tarxfv2.2.1.tar.gz 3、#cdgit-2.2.1 4、#makeconfigure 5、#./configure--prefix=/usr/local/git--with-iconv=/usr/local/libiconv 6、#makealldoc 7、#makeinstallinstall-docinstall-html 8、#echo"exportPATH=$PATH:/usr/local/git/bin">>/etc/bashrc>#source/etc/bashrc

三、安装中的错误

1、error: MSGFMT po/de.msg make[1]: *** [po/de.msg] Error 127

解决:yum install tk zlib-devel openssl-devel perl cpio expat-devel gettext-devel

2、errro: asciidoc: command not found
解决:yum install -y asciidoc

3、errro:xmlto: command not found

解决:yum install -y xmlto

四、检测

安装完成后,因为不在系统路径,所以要执行二、8写路径的操作。

#git --version

#git version 2.2.1
最后提醒,升级安装git的时候,最好一次安装依赖。

yum install -y tk zlib-devel openssl-devel perl cpio expat-devel gettext-develasciidocxmlto